Ask Your Question

wodiesan's profile - activity

2015-03-21 17:01:15 -0500 received badge  Famous Question (source)
2015-03-21 17:01:15 -0500 received badge  Notable Question (source)
2015-03-21 17:01:15 -0500 received badge  Popular Question (source)
2013-04-09 16:49:54 -0500 commented question ValueError: unsupported bit depth for aaline draw

That's what it returned within the error. I think I figured out what was happening: I binarized the image before trying keypoints. When I did it with the normal image it was fine.

2013-04-09 14:39:43 -0500 asked a question ValueError: unsupported bit depth for aaline draw

I'm working Keypoint Template Matching on a Raspberry Pi. I'm using LXTerminal, in the SimpleCV Shell. I've been trying to search for keypoints. When I type keys = area.findKeypoints() it takes a moment to do its thing. Then when I follow up with keys.draw() I get that ValueError, ending with (supports 32 & 24 bit). I checked the image and it is 640x480 images at 24 bit depth. Is there something I'm missing?

2013-04-06 07:15:16 -0500 commented question Raspberry Pi LXTerminal error in locating my jpg

So I got it to work. All I did was remove .jpg, and suddenly all is right with the world. Thanks for the help! I figured to try it without .jpg before starting all over again... wouldn't have thought about it if you didn't mention the file extension.

2013-04-04 20:44:10 -0500 commented question Raspberry Pi LXTerminal error in locating my jpg

Image("lenna") gives me <SimpleCV.Image Object size...... at memory location: (0x29a4440)>

Following yours and Reddit's advice: When I

ls -la /home/pi/kos/mrsamsa_front

It returned

-rw-r--r-- l pi pi *numbers* *date* *time* /home/pi/kos/mrsamsa_front
2013-04-04 15:04:03 -0500 asked a question Raspberry Pi LXTerminal error in locating my jpg

I'm having some issues with something really basic, and I'm hoping for an answer as to why this error is popping up. I'm trying to pull up my own photo and try some of the basics tutorial Features: leena portion on Raspberry Pi through LX Terminal. SimpleCV:2 is the error I keep getting.

Yes it's a JPEG, and I also tried adding a / in front of home/pi... here's the problem