Ask Your Question

noobcoder's profile - activity

2014-02-07 13:25:39 -0500 received badge  Famous Question (source)
2014-01-25 22:27:50 -0500 received badge  Notable Question (source)
2014-01-18 02:19:33 -0500 commented answer Error in Running Tutorial/Example Code

import cv2 doesn't work either. i appreciate all the help but i will just revisit this another time

2014-01-18 00:01:02 -0500 received badge  Popular Question (source)
2014-01-16 12:59:29 -0500 commented answer Error in Running Tutorial/Example Code

But the main issue for me isn't the OpenCV, its the incompatability in the OP: Reason: Incompatible library version: libSDL_ttf-2.0.0.dylib requires version 18.0.0 or later, but libfreetype.6.dylib provides version 14.0.0)

2014-01-16 12:58:25 -0500 commented answer Error in Running Tutorial/Example Code

Thank you for the response. When I type import cv, I get the standard import error for python modules. I followed your instructions but it says: Warning: Already tapped! Warning: opencv-2.4.7.1 already installed. I'm sure if I fix some path somewhere it can be fixed.

2014-01-15 18:53:21 -0500 received badge  Editor (source)
2014-01-15 18:50:35 -0500 commented question Error in Running Tutorial/Example Code

Latest Mac OS. I figured out its a problem with pygame but haven't figured any solution past that

2014-01-15 14:59:20 -0500 asked a question Error in Running Tutorial/Example Code

Here is the error:

NotImplementedError: font module not available
(ImportError: dlopen(/Library/Python/2.7/site-packages/pygame/font.so, 2): Library not loaded: /usr/local/lib/libfreetype.6.dylib
Referenced from: /usr/local/lib/libSDL_ttf-2.0.0.dylib
Reason: Incompatible library version: libSDL_ttf-2.0.0.dylib requires version 18.0.0 or later, but libfreetype.6.dylib provides version 14.0.0)

I do not know how to use libSDL_ttf/libfreetype and was wondering what I have to do to fix this issue. Thanks.

Edit: *When I was able to run by just typing simpleCV and then going through the examples, some of them would work and others wouldn't, giving the error above. Now, when I even type simpleCV, it says.

ImportError: Cannot load OpenCV library which is required by SimpleCV

I'm not even sure which OpenCV to re-install anymore, its very confusing

2014-01-15 14:57:36 -0500 asked a question Error in Running Tutorial/Examples

Reason: Incompatible library version: libSDL_ttf-2.0.0.dylib requires version 18.0.0 or later, but libfreetype.6.dylib provides version 14.0.0)

I was wondering how I can fix this issue. I am using the latest Mac OS, and I haven't used libSDL or libfreetype before. Any advice appreciated.

The full error is listed below: NotImplementedError: font module not available (ImportError: dlopen(/Library/Python/2.7/site-packages/pygame/font.so, 2): Library not loaded: /usr/local/lib/libfreetype.6.dylib Referenced from: /usr/local/lib/libSDLttf-2.0.0.dylib Reason: Incompatible library version: libSDLttf-2.0.0.dylib requires version 18.0.0 or later, but libfreetype.6.dylib provides version 14.0.0)