Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

SimpleCV and raspberry pi question

Hi all,

Right now I am evaluating SimpleCV for a realworld image processing application. The algorithm has been finalized (detect line, blob and then do something else and direct the motor to reject stuff) and tested on a laptop with Sony ps3 eye web camera. So far so good, but it has to be an embedded application.

My idea is to install SimpleCV on PI and port the same python code to PI. I got the raspi image from cl.cam.ac.uk.projects.raspberrypi.tutorials.robot.downloads which includes SimpleCV and some more. The camera gets detected as video0 and shows up in /dev. But when I try to use camera all kinds of problems crop up, like SimpleCV can't find the driver and the pi hang up or display goes off completely.

question is

  1. Is PI upto the task of what I am doing?, now it looks a little shaky to be used in industrial environment.

  2. How to get the eye reliably working on pi ? I am already using 7 port belkin powered hub.

  3. Is showing up as video0 enough ? or do I need to install ffmpeg also ?

  4. how to get rid off VIDIOC_QUERYMENU: Invalid argument error and grab images from camera.

Appreciate any help to resolve these questions.

Kannan

SimpleCV and raspberry pi question

Hi all,

Right now I am evaluating SimpleCV for a realworld image processing application. The algorithm has been finalized (detect line, blob and then do something else and direct the motor to reject stuff) and tested on a laptop with Sony ps3 eye web camera. So far so good, but it has to be an embedded application.

My idea is to install SimpleCV on PI and port the same python code to PI. I got the raspi image from cl.cam.ac.uk.projects.raspberrypi.tutorials.robot.downloads which includes SimpleCV and some more. The camera gets detected as video0 and shows up in /dev. But when I try to use camera all kinds of problems crop up, like SimpleCV can't find the driver and the pi hang up or display goes off completely.

question is

  1. Is PI upto the task of what I am doing?, now it looks a little shaky to be used in industrial environment.

  2. How to get the eye reliably working on pi ? I am already using 7 port belkin powered hub.

  3. Is showing up as video0 enough ? or do I need to install ffmpeg also ?

  4. how to get rid off VIDIOC_QUERYMENU: Invalid argument error and grab images from camera.

Appreciate any help to resolve these questions.

Kannan

PS: The link is garbled because of insufficient karma :(