Ask Your Question
0

Problem installing SimpleCV on OS X 10.6.8

asked 2012-12-06 17:23:03 -0500

Rasmus gravatar image

Hello,

I've I think I've installed all of the necessary software to run SimplyCv.

But attempting to start it from the command line I get a long line of errors that I do not know what to make of. (See below)

Could somebody point me in the direction of what went wrong in the installation process.

I use a macbook pro running 10.6.8.

Thanks!

–––––

Error Messages

Traceback (most recent call last): File "/usr/local/bin/simplecv", line 8, in <module> loadentrypoint('SimpleCV==1.3', 'consolescripts', 'simplecv')() File "/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/pkgresources.py", line 271, in loadentrypoint return getdistribution(dist).loadentrypoint(group, name) File "/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/pkgresources.py", line 2174, in loadentrypoint return ep.load() File "/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/pkgresources.py", line 1907, in load entry = import(self.modulename, globals(),globals(), ['name']) File "/Library/Python/2.6/site-packages/SimpleCV/init.py", line 3, in <module> from SimpleCV.base import * File "/Library/Python/2.6/site-packages/SimpleCV/base.py", line 22, in <module> import scipy.ndimage as ndimage File "/Library/Python/2.6/site-packages/scipy-0.12.0.devddd617d20120920-py2.7-macosx-10.8-x8664.egg/scipy/init.py", line 64, in <module> from numpy import showconfig as shownumpyconfig File "/Library/Python/2.6/site-packages/numpy-1.8.0.dev9597b1f20120920-py2.7-macosx-10.8-x8664.egg/numpy/init.py", line 137, in <module> import addnewdocs File "/Library/Python/2.6/site-packages/numpy-1.8.0.dev9597b1f20120920-py2.7-macosx-10.8-x8664.egg/numpy/addnewdocs.py", line 9, in <module> from numpy.lib import addnewdoc File "/Library/Python/2.6/site-packages/numpy-1.8.0.dev9597b1f20120920-py2.7-macosx-10.8-x8664.egg/numpy/lib/init.py", line 4, in <module> from typecheck import * File "/Library/Python/2.6/site-packages/numpy-1.8.0.dev9597b1f20120920-py2.7-macosx-10.8-x8664.egg/numpy/lib/typecheck.py", line 8, in <module> import numpy.core.numeric as _nx File "/Library/Python/2.6/site-packages/numpy-1.8.0.dev9597b1f20120920-py2.7-macosx-10.8-x8664.egg/numpy/core/init.py", line 5, in <module> import multiarray ImportError: dlopen(/Library/Python/2.6/site-packages/numpy-1.8.0.dev9597b1f20120920-py2.7-macosx-10.8-x8664.egg/numpy/core/multiarray.so, 2): Symbol not found: _PyCapsuleImport Referenced from: /Library/Python/2.6/site-packages/numpy-1.8.0.dev9597b1f20120920-py2.7-macosx-10.8-x8664.egg/numpy/core/multiarray.so Expected in: flat namespace in /Library/Python/2.6/site-packages/numpy-1.8.0.dev9597b1f20120920-py2.7-macosx-10.8-x8664.egg/numpy/core/multiarray.so

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2012-12-07 09:43:58 -0500

kscottz gravatar image

Snow Leopard installs are usually pretty easy. Did you install from source or superpack? Is that the full error message? What happens if you do an easy_install numpy?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-12-06 17:23:03 -0500

Seen: 274 times

Last updated: Dec 07 '12