Cannot load OpenCV library - OSX 10.9.5

asked 2016-01-26 10:43:49 -0500

visionless gravatar image

Hi,

I am having issues getting SimpleCV up and running with OSX 10.9.5. When I run 'simplecv' I get an error about OpenCV.

Administrators-MacBook-Pro-4:~ Simon$ simplecv RuntimeError: module compiled against API version a but this version of numpy is 6 RuntimeError: module compiled against API version a but this version of numpy is 6 Traceback (most recent call last): File "/usr/local/bin/simplecv", line 8, in <module> loadentrypoint('SimpleCV==1.3', 'consolescripts', 'simplecv')() File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkgresources.py", line 318, in loadentrypoint return getdistribution(dist).loadentrypoint(group, name) File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkgresources.py", line 2221, in loadentrypoint return ep.load() File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkgresources.py", line 1954, in load entry = import(self.modulename, globals(),globals(), ['name']) File "/Library/Python/2.7/site-packages/SimpleCV-1.3-py2.7.egg/SimpleCV/init.py", line 3, in <module> from SimpleCV.base import * File "/Library/Python/2.7/site-packages/SimpleCV-1.3-py2.7.egg/SimpleCV/base.py", line 60, in <module> raise ImportError("Cannot load OpenCV library which is required by SimpleCV") ImportError: Cannot load OpenCV library which is required by SimpleCV Administrators-MacBook-Pro-4:~ Simon$

I am able to import and identify OpenCV in python:

cv2.version '2.4.12'

Any ideas?

edit retag flag offensive close merge delete